KPN Experia Box v8 and PPPoE passthrough

A few weeks ago I got a new internet connection, after switching from Online to KPN (both are ISPs). It also came with a new modem, and the old one wouldn’t let me connect anymore. That was acceptable though, as the old modem (Speedtouch 564v6) was horrible.

Sadly, KPN doesn’t exactly have a reputation for delivering quality modems either, and the modem I got from them can’t be configured. With “can’t be configured” I mean that it doesn’t allow me to turn off the firewall, turn off the DHCP server, use UPnP, change the DNS servers, etc. It didn’t even have a telnet interface or other advanced configuration interface.

After spending a few hours with it (and after several configuration resets), I discovered that KPN edited the HTML of the web interface to hide a lot of elements that allow you to configure the modem. With Firebug I was able to recover some settings, including the ability to turn off the DHCP server and use my own instead.

But I wasn’t there yet. UPnP still didn’t work properly, and with manual port forwarding I couldn’t get some applications to work (probably because the firewall was still active).

Since the modem was already connected to my normal router, Apple’s Airport Extreme (nice stuff, but wouldn’t buy again) which has support for PPPoE, I decided to try using that. In theory if I managed to get that to work, I would completely bypass the parts of the Experia Box that make it so annoying. It would disable the firewall, DHCP server, it would let my own router handle UPnP, etc.

The web interface had a checkbox in the interface that said ‘PPPoE passthrough’. “Nice,” I thought. But after changing the settings of the router, it didn’t work. I hooked up my laptop (Mac) directly to the modem, but my laptop couldn’t connect either (the logs indicated that a timeout occurred after a connection was made). Maybe it was a Mac thing? I connected my Windows desktop as well, but the same thing happened there. Apparently ‘PPPoE passthrough’ was just a checkbox that didn’t do anything.

After several more hours of experimenting (I really needed this modem to work), I found a hidden web interface page that let me setup what I wanted in only a few clicks. Which is why I’m writing this article, as I don’t want anyone else to go through this mess.

To enable PPPoE passthrough on the KPN Experia Box v8, reset the modem first (hold the reset button until it restarts), then go to http://192.168.2.254/atmint.stm/3/1 and click Apply. Wait for the modem to restart and then configure your router (which should be the only device connected to your modem, preferably on LAN1). That’s all! The phone function still works, but the wireless router part of the modem should probably be turned off.

For Telfort users, the procedure is a lot more complicated, and I have not yet found the easiest way to do it. Read the comments for a few suggestions from readers.